Alphacat coins stuck in old O3 version

Dear sir/madam,

I did not know about the new O3 wallet. My old version of the O3 wallet in my android phone is stuck and does not open anymore see the picture in the attachment. I have Alphacat coins in this walles and I want to move them back to KuCoin

I download the new O3 wallet on my android phone and tried to upload my Alphacat wallet private key but it generates a different Alphacat wallet address and my coins are not in it.

Can you please help.

Kind regards,

Hi Marco

The old version is not available, you need to use the new version.
Can you provide your address? we will check it

I did not know about the new O3 wallet

Hello, I have the same problem as Marco. Can you help me?

Hi, please back up your private keys and import them to New O3 wallet. We are rebrand last year.
Download from App Store, Google Play, and official web:

Thank you, the problem has been solved

Hi Caroline,

I also have the same issues with my Alphacat coins stuck in the old wallet.

Any assistance would be appreciated?