Can't connect with the switcheo exchange when using non primary ledger NEO addresses created through the O3 wallet


#1

Hi,

Earlier today I tried to access the switcheo exchange through the O3 switcheo application. I have a couple of non primary NEO addresses that I created with my O3 wallet (imported them from the ledger).

So the first time it worked and I transfered the funds to the switcheo contract. Now when I try to connect the switcheo exchange to the wallet I get at the screen where you select your wallet and you need to press “accept”. After pressing accept it just goes back to “connect to O3 wallet”.

Now I can’t access or transfer the funds as I can’t connect the in-app switcheo exchange and the funds are in the contract.

The problem perseveres when I try it (with freshly installed O3 wallet) on another computer. I also reinstalled the NEO app on my ledger.

Please help, need to access the funds. Switcheo support can’t help and send me here.

Also, why isn’t there an option on the switcheo exchange via the browser to access multiple ledger NEO wallets?

Greetings.


#2

Hello,

Can you try to go to ‘Switcheo Legacy UI’ instead of the Switcheo main app? In there you can go to the login screen on the top right and then click connect to O3. After you connect, click Login and you will get to the exchange. On the bottom of the screen you can switch between v2 and v3. Note that v3 must be used for trading but it could be that some of your funds are still in v2.

If you still can’t get it to work can you maybe help by posting some screenshots? It’s hard to understand which screen exactly you are seeing and what is happening.

Regarding why there is no option on switcheo to access multiple ledger wallets. I think it might complicate the experience if there’s multiple wallets, but this is something only Switcheo can answer. We are just a gateway to interact with Switcheo’s exchange but do not control what is and what isn’t there.


#3

Hi. Tried with the legacy wallet on all versions of the network and didn’t work out.

  1. So I first go here and press accept: https://imgur.com/d1AGprt

  2. After pressing accept it just goes back here: https://imgur.com/W33gI8n

I can repeat step 1 and 2 all day if I wanted to… must have tried about 100 times yesterday.

So I can’t get the exchange to integrate that additional Ledger NEO wallet (same problem for some but not all other Ledger NEO wallets)

My ledger is all good, NEO app is opened and it reads “wake up, NEO… and an eye”


#4

Hello,

Just to double check. Your screenshots are from the regular Switcheo version, not the Legacy, but for Legacy it gives you the same problem?

Also, can you provide some extra information?
-What version of the O3 app are you on, and on which OS? (Mac/Windows?)
-What version of the ledger firmware are you using?
-What version of the NEO app on the ledger are you using?


#5

Legacy version gives the same problem

Latest o3 version, reinstalled to see if the issue would go away and also installed and tried o3 on another computer. Both Windows.

Latest Ledger Firmware (just checked)

Latest NEO app version (also reinstalled to see if the issue would go away)

I really don’t know what to do. Is this a known issue?


#6

Still not solved btw… just doesn’t work :frowning: funds stuck


#7

I have now been able to reproduce the issue. Will go through it with the team today see if we can find the cause of the problem.


#8

I am having the same problem as well, not working with either version of switcheo.


#9

We found the issue and it will be fixed in the next version of the O3 desktop app. It should be available later today on our website for direct download. The app stores will probably follow later this week after getting approval.


#10

Thanks a lot Arco. I must say your support has been extraordinary and supreme. Thank you so much. Looking forward to get past this issue asap and being a loyal user of O3.


#11

Happy to hear that! Once again apologies for the inconvenience caused and sorry to keep you waiting. The new version is now downloadable from the website: https://o3.network

Let us know if you have any other issues :wink:


#12

Still not working right? Using desktop o3 to connect to switcheo and keep getting the o3 window to pop up instead of being logged in?


#13

Hi,
Thanks for letting us know, we have taken a look into the issue and found the problem. There is a new version released on the website and will be available in the app stores when they are approved.

Thanks!