Closing the app


#1

I noticed a secure (?) close and used it last time I closed the wallet. Now I can’t find it again. Tried to x-out but I need to install the latest version and I can’t because the wallet didn’t close even though I hit the red x?

I tried to go to Stakeology and when it connected the page was replaced by this? (Sorry I thought I could attach an image I took of the page?) it says “Sorry this platform is not yet supported” I have version 2.0.4.

Thanks.


#2

Hi there,

To close the app, you will have to right click the icon in the toolbar and then click close. Just clicking the red x button on the browser of the app won’t work, this is new in the latest update to be able to connect to dapps etc.

Regarding Staketology. It’s strange that it shows the platform is not supported. This should only show up on mobile. While you are on the staketology page and showing the error, can you click F12 on your keyboard? This should load a separate screen with developer tools. Can you take a screenshot of the page you are seeing there? Then we can try and find out what the issue is.


#3

Here it is.


#4

Another view.


#5

Ah I’m sorry. Can you click on the Network tab in the right side developer tools screen and post another screenshot please?


#6


#7

Hi again, can you please help us with some additional info/screenshots?

The screenshots you made were from the developer tools page on the staketology page in your browser right? Can you do the same thing for when you are in the O3 app?

So:

  1. Open O3 app
  2. Go to apps page
  3. Open developer tools with F12, and click the ‘Console’ tab
  4. Click Staketology (it will open in browser but just ignore)
  5. Make screenshot of O3 app with developer tools page open
  6. Close Staketology in browser
  7. In O3 app developer tools click the ‘Network’ tab
  8. Click Staketology (it will open in browser but just ignore)
  9. Make screenshot of O3 app with developer tools page open

#8

Here is the App page and I don’t see Developer tools. I tried to click F12 but nothing?

![28%20PM|690x454]


#9

Second page


#10

Is there no way for you to open the same screen as in the earlier screenshot on the ‘Not supported’ page? It should be possible for you to open the exact same screen from the O3 app by pressing F12. If not maybe you can find it in the settings menu when you are in the app.


#11

Are you using Windows or OSX?

If you are using Windows, having the wallet open and pressing the “F12” key should open up the debugger to check for errors.

If you are using OSX, you can click “View” menu from the operating system menu bar at the top left of your screen.


#12

Here are the screenshots I took.

Thanks.


#13

Thank you for providing these screenshots! Very helpful. It looks like your wallet has been open for a very long time, so I’m wondering if maybe you downloaded version 2.0.4, but the version open is still an older version? Could you please confirm the version via screenshot of the version in the app?

For example:

My second thought is to try and fully quit the wallet by using the menu:

image


#14

I have 2.0.4. I installed it again from a download last week.


#15

I am wondering if using a different browser would be an option. Every time I click on Stakeology it goes to the page and for a second I can see what I want, but then it switches to the error message.

So I can’t get it up on a different browser. Any suggestions.


#16

Interesting, does this happen with other apps, or just staketology? You can actually open the staketology dapp from any browser. If you just navigate to the following link in something like Brave browser or Firefox, this should work as well.


#17

I opened Stakeology with Firefox and connected the app with little effort.

When Stadeology was open I connected to my O3 wallet. Nothing happened so I went to the stakeology app in the wallet. It opened in Chrome and didn’t give me the error message, but I couldn’t get any further. No Nodes showed nor did any thing else work. I closed Chrome and went back to Firefox. This time everything worked.

I still have an issue though as I did two transactions in my wallet totaling 1,000 ONT, and the ONT is separate? I noticed a link to swap the token and since I didn’t have a way to merge the two transactions I used it. I was hoping this would merge the two amounts?

Thanks.

Rory


#18

Hey there, glad to hear it worked somehow!

Can you post your address here so we can check on the transactions you mention?


#19

AZt6rsVmEAGbMN642bMvhj9LotW1q81dMW


#20

Hi again,

I looked into it but it seems you have 999 ONT not 1000.
If you stake your ONT, it will go into your staking account, meaning it won’t show up in your regular wallet anymore. Since you have staked 500 this is only viewable using the Staketology app after logging in with your wallet. The other 499 is in your wallet, as you can see probably when you open your O3 wallet. If you want to add the 499 ONT I would suggest you buy 1 ONT with O3 swap (https://swap.o3.app/) and then you can stake another 500, combining the two into one place.

Hope that helps!