Connecting Stakeology to Ledger Nano S


#1

O3 tray is spinning ready, not showing anything in Stakeology. I am using windows 10. I have updated O3 wallet, ledger live and ledger nano. I have cleared my cache and restarted. Please advise.


#2

Just to double check, which version of the O3 app does it show in the screen on the bottom left?

Also, is it the initial connecting? Or something when you make a transaction or do something else?


#3

Hi, thank for you reply.
The version is v2.1.6
It is the initial connection.


#4

When you open staketology and click connect, do you get the pop up screen asking for connection? Or do you get nothing at all?


#5

Yes I get a pop up screen in the right hand corner it requests access to my wallet, it recognizes the my Ledger and has the name of the wallet with a drop down menu. When I press connect it spins a blue circle and says ready, the Stakeology page shows nothing.

I looked up my address on neoeconomy.io and see there is a 1000 ONT stake in the Phecta Consesus Node associated with my address. AT2uWXbAZ9Wyoiy6wFccmDuWo3vy6xtq6E

I believe when I did the original stake I chose a different Consensus Node, Dubhe?


#7

Can you try to connect your ledger wallet to another app, like for example FTW?

Regarding which node you staked and when, that info is only available to you but I would assume that neoeconomy’s info is correct as they fetch the data from the Ontology blockchain.


#8

I am not familiar with FTW, could share a link?


#9

If you go to the apps list from within the app (icon in the middle on the left side bar), you can find it in there!


#10

Ok I tried to connect with FTW and nothing happened same window says ready but no connection or wallet showing in the app.


#11

Thank you, can you maybe also post a screenshot of that screen where it says ready?


#12

Sorry for the delay I was moving into a new place last week and was sidetracked, still unable to see my stake in the stakeology app. For some reason it will not let me attache the screenshot you have asked for? Please advise.


#13

Hello, could you please make sure you are using the latest version of the app. We just released a new update yesterday that fixes some bugs (v2.1.9).

https://o3.network/


#14

Yes I updated today.


#15

Just checked your address, and everything appears to be as you have stated previously.

As for the ledger connection I will check again on my end.


#16

@Tbone52 Just made a small adjustment for performance on the windows side. Could you please try out this new version:

https://o3.network/files/O3-Setup-2-1-10-WIN.exe


#17

I have downloaded and tried new version, no change.


#18

@Tbone52 sorry you are still having trouble with this. Just want to confirm my understanding of what you are experiencing.

Steps to reproduce:

  • Open O3 desktop wallet v2.1.10 on your windows computer
  • In your browser open https://ontstake.o3.app.
  • Notification window pops up on right hand corner of screen asking to select a wallet
  • Select your ledger device
  • Click Connect button

Expected result:

  • Should navigate back to browser and open stake information.

Actual result:

  • Notification window stays open with a circle spinner and the text ‘Ready’ under it.

Is this correct?

I have a couple of questions:

  • Which browser are you using? Have you tried different ones? Chrome, Brave, Firefox?
  • Is your ledger device connected to your computer, and your Ontology app open?

#19

Hello,
I am using Chrome, and all was connected I did it this time straight from the app address instead of going through O3.
I followed your steps and it worked this time.
Many thanks!