Lost password - how do I recover with my Private Key?


#1

Sorry for the completely noob question, but I’ve managed to misplace my password for the desktop OWallet. I do have my Private Key, however. Is it possible to recover the wallet with this? If so, how do I go about it? Thanks much!


#2

Hi there . Thanks for getting in touch.

The good news is, if you have your private key you can access your wallet again no problems. Are you using OWallet or O3 wallet? As they are a bit different. If you are not using O3 wallet, you can head to o3.network and grab the latest version which supports most of the same features as OWallet. From there you can just add a new wallet, enter the private key and it will ask you to create a new password, and you should be good to go.

Let me know if you have any problems


#3

Perfect! Thanks much for the help!


#4

No problem at all! Let me know if you need anything else. Have a great day!


#5

I too am a nooby and opened a 03 wallet, copied down my pass phrase, yet 03 says it ain’t so. I opened a new wallet, tried to send or receive my ont and yet it ask me for my pass phrase to send them. I am frustrated, depressed and bummed. all I was doing was try to collect ong. thank you for any help!


#6

I think you might be confused by the different sets of keys/passphrases. Let’s see if we can figure it out for you.

First of all, are you using O3 for mobile or for desktop?

When you made your wallet, you should have set up a passphrase and received an encrypted key afterwards. These two go together and you need both to access your wallet on a new device. If you are on desktop, everytime you unlock your wallet you will need the passphrase.

Can you remember setting a passphrase by yourself? I assume the pass phrase you are inputting is not the passphrase but the encrypted key. You need the passphrase that you created yourself.


#7

desktop / Arco, i have an encrypted key, and a pass phrase. when i go to send my coins to an exchange it ask for my pass phrase, i submit it, and it says it is wrong. i have tried it every which way i can and still no go. i wrote it down when i created the wallet, yet it doesn’t want to work. how can i change my pass phrase with out knowing the old one? Thank you Arco. i can’t find any other technical support except here. could you refer me to where i can find some from Ont? it’s there wallet is it not?


#8

Hi again,

I see… There must be something wrong with the passphrase you wrote down then, because there is no way that it can be changed… Do you also have the private key by any chance? This is different from the encrypted key, and you can use it to access your wallet without the passphrase. It also should have showed up when you created the wallet at first.

By the way the O3 wallet is made by O3 Labs, it’s not made by NEO and/or Ontology. We will try to help you as best as we can but without the private key or passphrase + encrypted key there’s not much we can do to be honest.


#9

I’m just reading back on your initial post again, and you mentioned you “opened a new wallet”. If you have multiple wallets, the keys and passphrase are separate for each wallet (unless you put the same passphrase of course). Maybe the passphrase you wrote down is for one of your other wallets?


#10

i stand corrected, your are business director of 03 labs. dang i wrote everything down except my encrypted key for this wallet. i have my pass phrase written down. encrypted code (why when that is readily available at the click of the hand) i copied.
i have all my other wallets written down, just this one doesn’t work! sh*t


#11

there goes a nice chunk of change. i can watch it grow, yet i can never touch it! frickin technology, gotta love it, gotta hate it.