My O3 NEO N3 wallet desappeared, can i recover it?

I have created a Legacy Neo wallet on O3 to do the migration. For that wallet I´ve all the keys.

Then I created a Neo N3 wallet during the migration.

Now that N3 wallet desappeared and I can´t recover it. I thought that the legacy keys were for the entire wallet not just for the legacy one.

Is there another way to recover it? It is still the same from migration and I have all the keys from the initial legacy wallet.


I had the exact same thing happen and need help as well

Hi fcosta, does the wallet disappear when you upgrade the software? Can you tell us more about it?

Yes. From 3.8.3 to 3.8.4.

I din´t look at my wallet everyday. I ´m the only one who uses my computer.

The wallet was fine, I did the migration and even vote in governance. But when I went to look at my balance in 1st october of unclaimed gas at governace it didn´t connect, then I went looking at the wallet and my N3 wallet was gone. no sign of it , even at the .json fila. The legacy one was fine. Only the N3 desappeared.

My Neo wasn´t robbed, still there but I can´t control it.

It wasn´t clear during migration that I had to make 1 backup for each account, In my ledger I have 1 seed for all.

Now I´ve lost All my NEO and GAS. Can you help me?

I have all the keys and password for my legacy account, I have the hash from migration, the logs on migration site and the password for the N3 wallet. And I used the same computer and connection for all the process. Its the same IP address.


Literally the same for me as well, wallet just gone. Only user of the computer and my version upgraded to .4 as well.

Please refer to the attached picture on how users could switch to the N3 network(wallets show up here).

Hi fcosta, we are sorry to hear that. Generally, the wallet created would not disappear for no reason.
Try to restore the disappeared wallet following this method:

STEP 1 Please go to:
C:\Users[your username]\AppData\Roaming\O3\storage
STEP 2 Try to find files named nep6_neo3_wallet and re-import the wallet with the password you have set up.


Hi Caroline,

Already tried that and didn´t work. The wallet data is gone.

I have a ledger for years and never had to use the seed phrase to restore it.

With your wallet I´ve had it for a month to do the migration and you release an automatic update that erases my new n3 wallet and now I´ve lost all my money. very disappointed and angry with that.

Hope you can find a way to solve this.


Hi fcosta, the wallet desktop won’t erase wallet data with the automatic update. We are very sorry to hear you lose your assets, you must feel overwhelmed.

But there are possibilities that wallets disappear accidentally, mostly from an unexpected system shut down or crackdown.

We are eager to help you restore the wallet, but without a private key, it is not possible. It is stated in the migration guide that it is essential to back up private keys and passwords as soon as a new wallet is created, or assets would not be retrieved due to unpredictable accidents.

HeY there did you ever figure it out or recover the wallet. Mine is still gone as well

Lost wallet as well.
Updated two days ago to 3.8.7, voted on governance, today I want to check and NEO3 wallet is gone. Old NEO2 is still there though.

Obv I can’t find were I stored the pk.


Elvan_Lukas, you can re-import the wallet if you hold private keys.


Happened to me as well

I hope that I’ve got my priv keys stored somewhere I forgot otherwise I’m fucked as well.

You really should look into this.

1 Like

Hello guys, i have almost the same problem like you all, i have migrated my neo in early bird migration, crated new wallet in o3 on the same wallet where i had my neo in neo legacy. So now i have new laptop, and i wanted to look in to my wallet, i can connect easy to my neo legacy wallet, ofcourse there is no neo in there, because i migrated them to neo3. But when im trying to log in to my neo3 wallet, wallets is asking to upgrade your neo3 address to N3MainNet, the wallet is asking a private key for unlocking wallet, i have tried all my passphrases many times , I have my encrypted key from neo3, but it is not enough to unlock my wallet? i dont understand why it is asking for private key? why after upgrade i cant even look in to my neo3 assets , please help me :slight_smile:


If a you’ve got any issue? ‘Just contact 03wallet support on there whatsap for assistance and clarification, they are fast and reliable

Same problem here. I migrated to N3 created a new wallet within my o3 wallet assuming it was connected with ledger because I have the N3 app on my ledger. Funds are now stuck in a watch only wallet with no recollection of creating a password for it… Seems like an internal scam and this project will not make it vary far unless reparations are made. Any advice or help welcome.

1 Like

I had same issue but it got resolved immediately I contacted o3 wallet support number I got on the forum here ,I think you should write to them too

1 Like

Now the support is asking for my ledger seed phrase… seems like a scam. How did you contact them?

exact same thing happened to me
let me know if you get any where with that thanks!

Let me be honest at the start I refuse because I was scared of loosing my funds ,but when I provided what the asked me with the new wallet I opened

They got my resolved and I had all my funds in my ledge intact ,they only have one number which is +17076829208

1 Like