Switcheo not linking with LEDGER through O3


#1

My Ledger has the latest firmware + latest O3 wallet update + latest NEO ledger APP. When I try to connect to Switcheo through O3 wallet - I receive a DENY or ACCEPT option for my Ledger Wallet linked to O3. When I click ACCEPT - nothing happens - screen returns to “Connect to O3 wallet” button with Neo Wallet + Etheruem wallet listed on the left hand side.

So, Switcheo sees my Ledger linked O3 wallet (sees the name of the wallet) yet will not allow me to actually connect it.

All other functions within O3 wallet and with other Dapps appear to work fine, just not Switcheo. Switcheo used to work just fine with my Ledger. Now it doesn’t.

Please help!

THX


#2

I’m having the same issue. Help me


#3

Are you using a VPN? For some reason Ledger + Switcheo + VPN doesn’t work. Turn off the VPN and it works. Let me know how you make out.


#4

Hi everyone!
We have identified an issue with logging in to Switcheo. We have fixed it and released a new version on the website. It will take a little longer for the app store versions to be approved and released, but it’s in progress.

Sorry for the inconvenience. Please check out the new version and let us know if you are still having trouble.


#5

Sorry ignore my previous VPN comment, that was for executing transactions. Use the Opera browser, that worked like a charm. It does sound like they may have now fixed the issue.


#6

I use O3 on Ubuntu 16.04 with ledger nano s. I have tried today to connect to switcheo and could not. With not ledger account I can connect to switcheo, but with ledger not. When I click on the Switcheo APP, switcheo page opens, then from the connect wallet page I I click on the CONNECT TO O3 WALLET button, O3 allows me to chose with address to use, if I chose the Ledger one, I get the “Ready” screen with the rotating blue O3, and it stays like this forever while switcheo is still not connected. I have O3 version 2.1.8, Ledger firmware 1.5.5 and NEO app 1.3.3. Is it a known issue? is there is fix? Thank you.


#7

@gipi
Thanks for catching this. We are experience some minor turbulence while migrating to the new OS level tray window. However, now it should be fixed in the latest version just updated on our site, 2.1.9.

Could you please give it a go, and let us know if you have any more issues?
https://o3.network/