Unable to claim FLM with ledger

Hi im trying to claim my flm from flamingo and I get an error that says “ here was an error signing this transaction. Please make sure you have the correct Ledger app open”, im using the latest 3.8.7 version , ledger nano x and the latest Neo app for ledger available. This happens on firefox and chrome.

Please tell me how to proceed thanks.Screen Shot 2021-11-02 at 11.39.52

Hi Mack, thank you reporting the issue and we will fix the problem in 1-2 working days. We are sorry for the inconvenience caused and the technical support team is working on it.

Best regards

Thank you so much, looking forward for your reply

Hi Mack, if you have urgent usage, please use 3.8.4 instead.


We will keep you updated.

Best regards

I already tried 3.8.4 i dosnt work…. it gives the same error

Can someon give me an answer?

Hi Mack,
Make sure your ledger app is opened when you sign the signature.


there is no sign! that’s the whole point of course the ledger is opened with the neo app that’s basic

Hi Mack, we suggest you to use a Nano S instead, the claiming is failed for some unknown issues and the team is bridging the Nano X and O3 wallet in a full scale.