Unable to Claim or unstake

Hello o3,

I am experiencing issues regarding the communication of my o3 wallet linked to the ledger with flamingo.finance and mymingo.finance.

With flamingo.finance I receive an “unknown wallet error” when clicking the claim button even though my wallet is loaded.

With mymingo.finance I get to the signature and it gives me “error: 'There was an error signing this transaction. Please make sure you have the correct Ledger app open.”

I have used Neoline wallet to test and I am able to sign and transact through the wallet so have narrowed it down to the o3 application.

I am unable to claim, swap, unstake or do anything regarding my wallet through o3.

My browsers adblock is off, VPN is off, tried multiple browsers, tried multiple operating systems, have all up to date updates for o3, chrome, ledger, ledger neo app.

I am not sure what else to try as I would like to claim my staking rewards but am completely unable to because I have done it through o3.

Thank you.

Anything from o3 Support staff?


If I understand correctly, you made these operation with Ledger connected on O3 Wallet right?
Please check your UTXO is not too much (usually it should be aroud 1) https://utxo-manager.o3.app/

There might be some issues when Ledger interact with defi project
I would suggest create/import a local address on O3 wallet and use this address to trade.

Thank you for the reply Caroline!

Yes, my O3 is using my imported ledger wallet as I want to have my crypto as secure as possible.

When attempting to utilize the UTXO https://utxo-manager.o3.app/ I am unable to see the entirety of the wallet as it just shows the connected address and the dropdown does not display the UTXO’s.

I have attempted to rectify this using brave browser and safari and had no luck.

Is there a more official channel to receive support? The community service provided here is literally the worst I have experienced in the space.


I have checked with dev. this might be the connection issue between Ledger and O3 wallet,
please reconnect the Ledger to O3 wallet and try again on Flamingo, it would be fine

you can also join our telegram and discord for troubleshooting, we have some admin there.