Ledger nano not recognized by O3

I connected to 03 via ledger over a year ago and stored and staked ONT. I am now trying to connect my ledger to O3 but does not recognize device. I have reset my ledger and reinstalled the ONT app on it but still doesnt connect. The ledger reads no public key requested yet. And the O3 has a blue spinning circle. The O3 app says open ONT app on your ledger. Cant get past this part.
Please can someone help

Hello,

I have the same problem just with NEO, supposly they are in my O3 saving wallet but cant reach them.
When i try to connect my Ledger Nano S with the O3 wallet, i also get the same message: “No Public Key Requested Yet”. What to do now???

Can someone please help!!!

hi,
Could you provide the screeshot and details about your question for us? We are now testing the new version of ledger, and this problem will be solved soon, it can be used normally after the test is completed.

Best


This is what I meant

When I click on the above message, my saving wallet, I end up on this screen

Whether I try to access funds on staketolgy or ledger wallet on O3, or import ledger- I get same message on ledger “no public key request yet”

I’m confusing about the two screenshots. the first one is showing that sent to your saving wallet and the second one is showing that there are two NEO in your wallet, right? Currently, O3 is upgrading and the new version will back in June. Please do not worry, your assets are not missing.

Received, we are now testing the new version of the ledger, your problem will be solved soon.

hi, the ledger problem resolved. Please try to re-download the O3 wallet from the official website and feel free to ask me if you still have questions :slight_smile:

I have same problem, nothing changed. The O3 app or staketology does still not recognize the ledger anymore. The O wallet does recognize the ledger but shows a different ledger address (with no ONT or ONG) than the O3 Wallet ledger address.

ALL my ONT and ONG are on the ledger on O3 application. I only have one ledger

O3 currently supports neo and ont addresses, so please select the '‘Ontology only addresses’ that showing in the pic before import ledger wallet. It may help you solve the problem.

My ledger was already previously imported on the O3 APP and has my ONT and ONG stored, but I cannot connect. If I try to re import ledger, it also does not connect. Just says open ont app. But my ledger says no public key requested

Could you provide the screenshot according to the ‘open ont app’, and ‘no public key requested’ that we can check and actually know what kind of situation you met? Thanks.

Ive already done this. Please scroll up 9 replies 3 pics . Not sure if this is important but when I use the Owallet, the ledger shows as a different signing address

The issue has not been fixed, I still cannot connect ledger to O3 wallet to access my ONT