Staking question


#1

Hello,

I’m new with staking and don’t know why I can’t stake. I have over 500 ONT, my wallet is connected with a Ledger. When I open the staking app it already goes wrong with step 1:
Upon opening the Staketology dapp, you will be prompted to connect one of your accounts. Please select the account you would like to manage your stake with, and click “Accept” to initial the connection between your O3 wallet and the Staketology dapp.

It does not ask this. Next round in: Null Block.
When clicking create new stake the list with Nodes is empty.

What I’m doing wrong?

Update: The same problem with the new neo economy app. It seems to open at random. My biggest guess its Bitdefender that’s blocking something but I can’t figure it out since it’s so random. I turned all protection from Bitdefender down and after openening the O3 wallet I can open the stake app with nodes. But only once! If I close the app then I can’t open it again! Blank. This makes no sense. So I can’t figure out what’s causing these problems.


#2

Hi there, just to check, you are on a computer and not mobile right? Can you let us know which OS you are on, and which version of the O3 app you are using?


#3

Yes desktop Windows 10 pro, O3 version 1.2.2


#4

@nick any idea?


#5

It very strange, I have tried more times and this is what happened. Problem includes all 3 apps that ask you to select an account: NNS, Neo economy and staketology.

With Bitdefender on:
Neo economy opens sometimes with 3 tries, 5 tries, 15 tries totally random. But sometimes the background off the app is dark gray and sometimes white.
NNS same problem opening but after selecting the account its just a blank page with <back but is unclickable.
Staketology unable to work.

With Bitdefender turned off one by one I see an improvement with Advanced Threat Defense turned off. This increases the chances of opening the apps, but it’s still random and NNS is still a blank page.
At least I can open staketology a few times but it’s acting weird. The first time after opening O3 I can log in, but when closing the app, staketology can’t be opened again. But when I open Neo economy then at random I can open staketology a second time. So after closing staketology I can only login a second, third time if I can open a different app which also opens at random.

If it really was Bitdefender than the apps should work when turned off. Maybe there’s nothing we can do about it.


#6

@rahx360
We’ve changed the way that dapps interact with the wallet wince version 1.2.2. Have you tried our latest wallet version 2.0.2?

https://o3.network/


#7

I noticed the way apps interact with my browser changed. It works normaly since then. Only NNS is blank, not sure what this is supposed to do.